En poursuivant votre navigation sur ce site, vous acceptez l'utilisation de cookies pour vous proposer des contenus et services adaptés. Mentions légales.

Forum - Questions sur Access - Probléme avec .accdb


 

actif  Sujet n° 842

le 03/05/2020 : 19:33
par jfs

Anonyme

visiteur

Bonjour Pierre

J'ai une base qui fonctionne bien en mdb sous Access 2003 et Access 2010. Aucun soucis de compilation.

Si j'enregistre la base en .accbd  je ne peux plus la compiler car j'ai des erreurs.

A un endroit j'ai deux recorset qui sont imbriqués

Le premier dans uns boucle (For_next) va me récuperer des N° de vendeurs dans une requête

et le deuxeme utilise ce N° pour collecter des valeurs de vente mois par mois dans une boucle également

C'est un niveau de ce deuxième rst, à rst.edit  que j'ai le message "Membre de méthode ou de donnée introuvable"

Moi aussi du coup je suis en boucle et je n'arrive pas à voir ce qui coince.

ça m'énerve un peu mais la base peut toujours tourner en mdb par contre sur Access 2016 je ne suis pas certain que ça passe.

as tu une petite idée sur le problème

Merci

Poster une réponse Haut  
Réponse n° 1
--------
le 04/05/2020 : 13:31
par 3Stone

3Stone

Administrateur


Bonjour,

Recordset.Edit (DAO) demande la référence "Microsoft DAO 3.6 Object Library"

Je suppose qu'elle est activée ?

J'ai aussi déjà eu des problème avec Access 2010 sous Windows 10...

Dans ce cas, la solution a été de faire tourner Access en "mode compatible".

  • Clic droit sur l'icône du programme Access, et choisir dans le menu "Résoudre les problèmes de compatibilité".

Cordialement, Pierre(3Stone)

Poster une réponse Haut  
Réponse n° 2
--------
le 04/05/2020 : 19:55
par Jfs

Anonyme

visiteur

Bonsoir

DAO 3.6 avait disparu 

Merci pour la qualite et la rapidite de ta reponse 

Cordialement 

Jfs

Poster une réponse Haut  
actif sujet actif   clos sujet clos   Important! Important!   Nouveau Nouveau message
Rectifier Rectifier message   Clôturer Clôturer sujet   Remonter Remonter  
Catégories de discussion  Forum  



Vous êtes ici :   Accueil » Forum » Questions sur Access » Probléme avec .accdb